STIC Discussion:STIC I - exercice 4 (Volt)

De EduTech Wiki
Aller à : navigation, rechercher

1 Thematique exercice 4 -- Stephanie Perrier (discussion) 15 novembre 2015 à 20:14 (CET)

Bonjour,

J'ai réalisé il y a quelque mois déjà une video avec le logiciel Videoscrib qui contient des images placées au fur et à mesure, commentées par une piste audio. Etant donné qu'il n'y a pas de personne filmée et de plan différent, puis-je quand même prendre cette video pour l'exercice ?

Merci de votre réponse & bonne soirée Stéphanie

1.1 Re: Thematique exercice 4 -- Daniel K. Schneider (discussion) 15 novembre 2015 à 20:31 (CET)

Oui, puisque l'énoncé ne dit pas exactement comment la vidéo doit être faite ....

Faites juste attention aux autres contraintes (éléments interactifs, sous-titres...)

- salutations !

2 Souci de timer sur vidéo -- Lydie BOUFFLERS (discussion) 2 décembre 2015 à 21:18 (CET)

Bonjour,

J'ai un souci avec le timer de la vidéo lorsque j'insère de l'interactivité (ie >> la vidéo arrive a un endroit de la vidéo). Concrètement, le timer de la vidéo (en bas) ne démarre pas.

J'ai essayé pas mal de choses en long, en large et en travers mais je suis entrain de me dire que peut être Leanback player ne peut pas faire ce genre de chose.

Avez vous déjà essayé et/ou trouvé une solution ?

Merci par avance,

Lydie

2.1 Re: Souci de timer sur vidéo -- Mattia A. Fritz (discussion) 3 décembre 2015 à 14:26 (CET)

Bonjour Lydie,

pouvez-vous montrer un exemple avec le problème svp? Avec seulement la description je ne suis pas sûr de comprendre.

Merci, Mattia

2.2 Re: Souci de timer sur vidéo -- Lydie BOUFFLERS (discussion) 3 décembre 2015 à 15:20 (CET)

Bonjour Mattia,

Merci pour votre retour.

Pour l'histoire :
J'ai créé ma fonction qui m'amène à un temps choisi de la vidéo et qui lance la lecture au bon endroit comme prévu (par l'intermédiaire de la fonction play() ). Si la vidéo est en cours de lecture, tout fonctionne correctement.
Malheureusement, si la vidéo est arrêtée (pas en pause), on entend uniquement la piste son de la vidéo au bon endroit mais l'image reste bloquée sur le poster (option définie dans la balise <video> avec le bouton lecture "BigPlay" en overlay au centre de la video). J'ai alors supprimée l'option "poster" (dans la balise <video>) et l'option "BigPlay" (dans les options extracontrols du player leanback) pensant résoudre le problème. Effectivement, tout se déroule bien. La vidéo démarre à l'endroit choisi mais la barre de contrôle dans leanback player reste figée (00:00 / 00:00) comme le montre la capture d'écran ci-dessous.

Ex4 LBO.png

Si l'on veut faire pause ou revenir en arrière avec la barre de défilement on est obligé alors de cliquer au moins une fois sur la vidéo elle-même, car la barre de contrôle ne répond pas.

Cela est-il un bug de leanback player avec des interactions HTML5/JS/DOM ? Car, dans les démonstration w3schools, ces fonctions marchent correctement (boutons html et barre de contrôle de la vidéo), mais w3school n'utilise pas leanback player. J'ai vu aussi que dans votre cours vous avez créé des boutons "play" "pause" "stop" et "volume" et la barre de contrôle était désactivée sur la vidéo (il me semble aussi qu'il ne s'agissait pas de leanback player).


Avez vous une idée du souci ?

Merci par avance,

Lydie

PS: testé sur Chrome et Firefox

2.2.1 Re: Re: Souci de timer sur vidéo -- Mattia A. Fritz (discussion) 3 décembre 2015 à 15:39 (CET)

En effet, il peut y avoir une incompatibilité entre l'API de HTML5 et l'API de LeanBack. L'un des objectifs de LeanBack est celui de créer une sorte d'abtraction de l'API HTML5 pour garantir la compatibilité entre navigateurs. Donc il me semble en effet une explication possible, même si je n'en suis pas totalement sûr.

Si vous voulez, vous pouvez créer une copie de votre travail dans lequel le problème se manifeste et m'envoyer le lien comme ça que je puisse regarder sans vous bloquer avec le développement de votre version finale.

M.

2.2.2 Re: Re: Souci de timer sur vidéo -- Lydie BOUFFLERS (discussion) 3 décembre 2015 à 20:29 (CET)

Rebonjour Mattia,

OK, je vais cela. Le temps d'uploader sur le serveur et je vous envoie le lien.

Merci encore !!

Lydie

3 captcha -- Nina.devincent (discussion) 4 décembre 2015 à 11:19 (CET) -- Nina.devincent (discussion) 4 décembre 2015 à 11:19 (CET)

Bonjour,

Dès que je souhaite faire une modification dans le wiki, on me mets la captcha à chaque fois. Est-ce possible de remédier à cela? J'avais poser la question sur la page même que je souhaitais modifier mais je n'ai aucune réponse ( http://edutechwiki.unige.ch/fr/Discussion:E-Adventure )

Merci, nina devincent

3.1 Re: captcha -- Nina.devincent (discussion) 4 décembre 2015 à 11:19 (CET) -- Daniel K. Schneider (discussion) 4 décembre 2015 à 11:44 (CET)

oui c'est fait. Chaque nouveau utilisateur doit faire des captcha, sauf si on le met dans un group spécial.... on a du vous oublier où vous n'avez pas fait l'atelier d'initation ....

(il faut effectivement utiliser une page discussion de STIC pour qu'on puisse voir ... je ne suis pas toutes les pages discussion).