STIC Discussion:STIC I - exercice 1 (Tetris)

De EduTech Wiki
Aller à la navigation Aller à la recherche

Editeurs HTML - lequel ? -- Daniel K. Schneider (discussion)

Quel éditeur HTML utilisez-vous ?

Validation page html -- Margot.baehler (discussion) 2 octobre 2013 à 19:17 (CEST)

Bonjour !

J'ai commencé à créer ma homepage à TECFA. Le souci, c'est que lorsque je mets mon url sur http://validator.w3.org, il m'indique qu'il n'y a pas d'erreurs, mais des warnings... Je n'arrive pas à voir pourquoi.

Voici l'url de ma homepage : http://tecfaetu.unige.ch/perso/maltt/baehlem0/

J'espère que vous pourrez m'aider ! Bonne soirée,

Margot

Re: Validation page html -- Daniel K. Schneider (discussion) 2 octobre 2013 à 21:05 (CEST)

C'est tout bon. Le warning dit juste que HTML5 est provisoire et que le valideur ne peut pas tout garantir :) Je cite:

The validator checked your document with an experimental feature: HTML5 Conformance Checker. This feature has been made available for your convenience, but be aware that it may be unreliable, or not perfectly up to date with the latest development of some cutting-edge technologies.

STIC-I-Ex.1.Question sur Homepage http://tecfaetu.unige.ch/etu-maltt/tetris/ -- Fanleshan (discussion) 3 octobre 2013 à 10:52 (CEST)

Bonjour, en suivant la consigne de : 3 Projet 1/Tâches 3.4

1. j'ai copié les 5 fichiers dont welcome.xml modifié, les 4 fichiers save as localement.

2. je les ai mis dans le répertoire : tecfaetu.unige.ch/web/etu-maltt/tetris/fan4 via Cyberduck.

3. la page travail ne s'affiche pas.

Dans quel endroit pourrait avoir un problème ? Merci pour vos attentions. Leshan FAN

Re: STIC-I-Ex.1.Question sur Homepage http://tecfaetu.unige.ch/etu-maltt/tetris/ -- Daniel K. Schneider (discussion) 3 octobre 2013 à 17:48 (CEST)

Simple, vous avez mal réglé les permissions de votre client FTP (Cyberduck). A part vous, personne ne pouvait voir vos fichiers. J'ai corrigé et cela marche.

Cherchez une solution sur Google, genre "permission cyberduck", ce qui donne par exemple

Problème tâche 3.4 -- Luca.giachino (discussion) 7 octobre 2013 à 21:05 (CEST)

Bonsoir,

Je me permet de vous écrire car j'ai un problème pour la tâche 3.4. En effet, j'ai suivi la consigne à la lettre donc j'ai créé et édité ma home page en xml.Après avoir terminé, j'ai copié les cinq fichiers par SFTP dans mon espace travail. Par contre, lorsque je tente de regarder les modification sur mon browser à l'url suivante: http://tecfaetu.unige.ch/etu-maltt/tetris/giachil0. , il y a la fin de mon codage XML qui ne s'affiche pas. J'ai tenté de voir si il y avait un problème dans l'écriture/ le placement de mes balises en me basant sur l'exemple proposé dans les cinqs fichiers de l'exercice mais je ne vois pas oú se trouve le problème...

J'espère que vous pourrez m'aider,

Bonne fin de soirée.

Giachino Luca

Re: Problème tâche 3.4 -- Daniel K. Schneider (discussion) 7 octobre 2013 à 22:34 (CEST)

Vous ne suivez pas vraiment les consignes à la lettre :)

Consigne #1: Utiliser un éditeur XML pour éditer !!!

En gros, vous utilisez des balises qui n'existent pas. La moindre des choses que vous devez faire - même si vous croyez les fausses rumeurs comme quoi c'est plus simple de ne pas apprendre un éditeur XML - est de valider votre XML. N'importe quel éditeur XML le fait, même un très mauvais.

[Xerces-J 2.9.1] Validating "giachil0.xml" against "file:/C:/Users/dschneid/Desktop/tmp/travaux.dtd" ...
Ln 21 Col 14 - Element type "exercice" must be declared.
Ln 22 Col 22 - Element type "exercice-number" must be declared.
Ln 42 Col 12 - The content of element type "course" must match "(title,url?,instructor?,exercise+)".
3 Errors

Donc exercice n'existe pas par exemple. La balise s'appelle exercise, vive le King's English !

Re: Re: Problème tâche 3.4 -- Luca.giachino (discussion) 8 octobre 2013 à 10:52 (CEST)

Of course ! Merci beaucoup pour la réponse, je comprends mieux ce qui ne jouait pas ! bonne fin de journée.

Tâche 1 - problème encodage des caractères et validation HTML5 -- Mfallouji (discussion) 11 octobre 2013 à 11:20 (CEST) -- Mfallouji (discussion) 11 octobre 2013 à 11:20 (CEST)

Bonjour, J'ai le même souci qui nous a été montré durant le cours avec l'encodage des caractères et la validation du code HTML:

1- Problème avec l'encodage des caractères accentués. Voici le lien de ma page: http://tecfaetu.unige.ch/perso/maltt/alfallo7/welcome.html

J'utilise BlueGriffon pour créer la page et mis l'option "Encoder tous les caractères spéciaux HTML". Pour transférer le fichier j'utilise WinCSP et j'ai bien pris soin de choisir le mode texte pour le transfert. Le charset de mon fichier HTML et UTF8. Malgré tous ces réglages je n'arrive pas à afficher correctement les caractères accentués.

2- Mon fichier HTML est par la même occasion non valide.

Votre aide est la bienvenue, Cordialement, Mohamed

Re: Tâche 1 - problème encodage des caractères et validation HTML5 -- Mfallouji

Voilà une chose bien étrange: Sans rien changer le problème n'apparaît plus et mon fichier est valide. !!
A mon avis plutôt un problème lié à la config de votre navigateur. Ne faut pas le forcer à faire du ISO par exemple .... enfin si TVB pas besoin de s'inquiéter .... - Daniel K. Schneider (discussion) 11 octobre 2013 à 12:09 (CEST)

Où doit-on placer la présentation impress ? -- Margot.baehler (discussion) 11 octobre 2013 à 18:30 (CEST)

Bonsoir,

Je me demandais où nous devons placer la présentation impress et sa feuille de style? Je pensais le placer dans (vue SFTP) : tecfaetu.unige.ch/web/etu-maltt/tetris/mon login/ Est-ce correct ?

Je vous souhaite un bon week-end, Margot Baehler

Re: Où doit-on placer la présentation impress ? -- Daniel K. Schneider (discussion) 11 octobre 2013 à 18:43 (CEST)

Je n'ai rien indiqué, donc c'est à vous de décider. Je ne le placerais pas au niveau "mon login". Selon mon expérience, il faut garder propre le haut d'une structure de fichiers. Si vous considérez que c'est juste un exercice mettez les dans /web/etu-maltt/tetris/mon login/stic-1/ex1 ... sinon plutôt dans vos pages perso: /web/perso/maltt/votre login/

Sinon, j'ai aussi corrigé une faute de frappe dans la page, donc c'est "stic-1" au lieu de "stic".

/web/etu-maltt/tetris/____/stic-1/ex1/
/web/etu-maltt/tetris/dupond/stic-1/ex1/

Re: Re: Où doit-on placer la présentation impress ? -- Margot.baehler (discussion) 11 octobre 2013 à 19:05 (CEST)

Merci pour votre réponse !

Ainsi, je devrais créer aussi des dossiers dans /web/perso/maltt/mon login ? Par exemple, /web/perso/maltt/mon login/stic/impress pour ma présentation impress ?

Re: Re: Re: Où doit-on placer la présentation impress ? -- Daniel K. Schneider (discussion) 11 octobre 2013 à 21:38 (CEST)

Comme vous voulez :) A mon avis c'est une bonne politique: 1 "sujet" = 1 répertoire. Savoir organiser à la fois un site et (surtout) votre PC est une très bonne chose....

Re: Re: Re: Re: Où doit-on placer la présentation impress ? -- Margot.baehler (discussion) 13 octobre 2013 à 21:13 (CEST)

Merci beaucoup pour votre réponse !

Bonne soirée à vous, Margot

Besoin de précision : dater et signer chaque page -- Margot.baehler (discussion) 15 octobre 2013 à 13:10 (CEST)

Bonjour,

En relisant les consignes générales pour les travaux du cours STIC, j'ai vu qu'il est indiqué que "Chaque page déposée sur notre serveur doit être datée et signée avec votre page travail ou encore votre home page !"

Je ne comprends pas vraiment ce que cela signifie... Est-ce que cela revient au fait de remplir la page travaux avec les informations demandées (nos infos personnelles, le titre de chaque page, la date de reddition...) ?

Bon après-midi à vous, Margot

Re: Besoin de précision : dater et signer chaque page -- Daniel K. Schneider (discussion) 15 octobre 2013 à 13:29 (CEST)

En gros le lecteur doit savoir par qui la page a été produite et quand. Donc:

  • il faut mettre une date qq. part (en bas de la page par exemple)
  • Faire un lien vers une page qui vous identifie, donc votre home page ou votre page travail. Donc quelque chose de type:

<a href="http://tecfaetu.unige.ch/perso/maltt/baehlem0/">Margot Baehler</a>, 15 octobre 2013.

ou <a href="/perso/maltt/baehlem0/">Margot Baehler</a>, 15 octobre 2013.

ou <a href="http://tecfaetu.unige.ch/etu-maltt/tetris/baehlem0/">Margot Baehler</a>, 15 octobre 2013.

Re: Re: Besoin de précision : dater et signer chaque page -- Margot.baehler (discussion) 15 octobre 2013 à 16:37 (CEST)

C'est noté, merci à vous, Margot

Présentation impress : les liens inclus ne marchent pas -- Margot.baehler (discussion) 15 octobre 2013 à 16:40 (CEST)

Re-bonjour,

Voilà un peu plus d'une heure que je cherche pourquoi je ne peux pas cliquer sur les liens inclus dans ma présentation impress. En fait je peux cliquer dessus, mais je n'accède pas aux pages qui y sont liées...

Vous la trouverez à l'adresse suivante http://tecfaetu.unige.ch/perso/maltt/baehlem0/impress

J'espère que vous pourrez m'aider,

Margot

Re: Présentation impress : les liens inclus ne marchent pas -- Daniel K. Schneider (discussion) 15 octobre 2013 à 18:51 (CEST)

Problème:

  • Le slide7 est posé par dessus le slide1, donc les liens dans le slide 1 est qui est posé dessous ne marchent pas.
  • Je n'ai pas de solution directe (pas le temps pour chercher/réfléchir), mais j'ai des suggestions:

Solution très facile: mettez le slide 7 plus petit

data-scale="1"

Solution plus intelligente: Créez un nouveau style ou modifiez les thoughts dans le CSS pour que cela prenne moins de place.

.thoughts {
   width: 1000px;
   height: 300px;  /* prend moins de place en hauteur */
   font-size: 60px;
   text-align: center;
}

PS: Les balises h1 ne sont pas stylés pour thoughts, faudrait le faire ou alors utiliser "big", par exemple

.thoughts h1 {
   display: block;
   font-size: 120px;
   line-height: 1;
}

Re: Re: Présentation impress : les liens inclus ne marchent pas -- Margot.baehler (discussion) 15 octobre 2013 à 21:32 (CEST)

J'ai essayé à partir de vos suggestions et cela fonctionne :-) Merci beaucoup, Margot

Associer feuille CSS dans un fichier XSL ? -- Margot.baehler (discussion) 24 octobre 2013 à 19:37 (CEST)

Bonsoir,

J'avais envie de modifier un peu le XSL de ma page travaux. J'ai regardé le Tutoriel XSLT débutant et au point 7, il est noté qu'on peut associer une feuille CSS dans un fichier XSL pour le résultat en HTML. J'ai essayé en incluant la ligne (le css étant dérivé du css associé à ma homepage) :

<link href="css-template-pagetravaux.css" type="text/css" rel="stylesheet"/>

et cela fonctionne, mais a-t-on le droit de le faire pour notre page travaux ?

Bonne soirée à vous, Margot

Re: Associer feuille CSS dans un fichier XSL ? -- Daniel K. Schneider (discussion) 24 octobre 2013 à 20:22 (CEST)

Bien sur :)

Effectivement, le XSLT produit du HTML simple et la feuille de style CSS va ensuite le styler comme il faut. Vous pouvez aussi regarder les autres promotions. Ce XML existe depuis 10 ou 15 ans :)

PS (ajouté): Interdiction totale de modifier le XML + DTD. Par contre, vous avez également le droit de modifier le XSLT. Il faut juste qu'on puisse lire les infos ...

Re: Re: Associer feuille CSS dans un fichier XSL ? -- Margot.baehler (discussion) 25 octobre 2013 à 11:56 (CEST)

Parfait :-) Merci pour votre réponse,

Bonne journée à vous, Margot

home page tecfa -- Fabienne Salamin 1 novembre 2013 à 10:12 (CET) -- Fabienne Salamin 1 novembre 2013 à 10:12 (CET)

Bonjour, j'ai transféré tous les fichiers de ma home page sur le serveur tecfa. Je les vois bien apparaître, mais quand je veux clique sur le lien - http://tecfaetu.unige.ch/perso/maltt/salamfa0- je vois tous les fichiers et dois clique sur index pour que mon site s'ouvre. Ou est l'erreur?? Merci pour votre réponse

Re: home page tecfa -- Fabienne Salamin 1 novembre 2013 à 10:12 (CET) -- Fabienne Salamin 1 novembre 2013 à 10:43 (CET)

Replace this text with your reply

Re-bonjour, entre-temps j'ai trouvé mon erreur. Donc merci de ne pas tenir compte de ma demande. Bonne fin de journée

Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Mohamed (discussion)

Bonjour, J'ai souhaité rajouter un clip youtube dans un slide avec le code suivant:

  <!-- slide 4 -->
  <div id="slide4" class="step slide" data-x="1000" data-y="1000" data-scale="1">
    L'intégration de composantes multimédias se fait d'une manière très simple ....<p></p>
    <div><iframe width="420" height="315" src="http://www.youtube.com/embed/yqQpp7UDRHI"></iframe></div>
  </div>

Avec IE 8, la vidéo s'affiche mais ne supporte pas impress.js (l'affichage des slides se fait sur une seule page html), sous Firefox j'ai juste un cadre noir et sous Chrome j'ai seulement le son !!

J'ai beaucoup cherché mais je n'ai rien trouvé. Merci pour votre aide. Cordialement,

Re: Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Mohamed (discussion) Daniel K. Schneider (discussion) 1 novembre 2013 à 14:13 (CET)

Bonjour, pour que je puisse me faire une idée, il faut mettre le tout en ligne (donc tous les fichiers).

Re: Re: Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Mohamed (discussion) 1 novembre 2013 à 20:08 (CET)

Bonjour,

Voici le slide en question: http://tecfaetu.unige.ch/etu-maltt/tetris/alfallo7/stic-1/ex1/tache5/ex1_tache5.html#/slide4

Tous les fichiers sont accessibles à l'adresse: http://tecfaetu.unige.ch/etu-maltt/tetris/alfallo7/stic-1/ex1/tache5/
Cordialement, Mohamed

Re: Re: Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Daniel K. Schneider (discussion) 4 novembre 2013 à 12:03 (CET)

A mon avis la video est placée sous un autre objet CSS. Ne devrait pas arriver, donc c'est un bug je pense (CSS3 n'est pas encore officiel et donc pas forcément super bien implémenté).

En tout cas dans Chrome cela marche. J'ai essayé de la bouger dans l'axe Z pour que cela marche dans Firefox, mais pas réussi ....

.videot {
   transform: translateZ(500px);
   -webkit-transform: translateZ(500px);
   -moz-transform:    translateZ(500px);
}

Il y a peut-être autre chose à essayer, mais je n'ai pas le temps. Donc soit

  • vous la tuez
  • vous mentionnez que cela ne marche que dans certains navigateurs
  • vous cherchez une solution sur le web (si elle existe)
  • servez cette vidéo autrement (Youtube utilise du non-standard ...)
Re: Re: Re: Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Mohamed (discussion) 5 novembre 2013 à 20:15 (CET)
Bonjour, Sur la base de vos indications et les recherches faites sur Internet, il semble qu'il y ait un souci avec l'intégration de vidéos dans les navigateurs ne supportant pas le HTML5. Une suggestion que j'ai essayé est d'utiliser la balise <video> mais qui n'a fonctionné qu'avec Chrome. N'ayant pas trouvé de solution, je vais finalement abandonné l'idée d'intégrer une vidéo dans la présentation. Dommage. Merci pour votre aide.
Re: Re: Re: Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Daniel K. Schneider (discussion) 6 novembre 2013 à 12:26 (CET)

Non, la balise vidéo fonctionne avec tous les navigateurs, sans problème .... YouTube ne sert pas d'une façon normale, ils ont un player compliqué qui essaye d'empêcher les gens à télécharger, etc. A mon avis une vidéo fonctionnera sans autre. Il faut juste payer attention à la non-standardisation des formats. "Webm" marche le mieux, mais pour couvrir tous les navigateurs il faudrait aussi servir un mp4. Ensuite, il faut déposer le tout sur un serveur.

Lire: http://edutechwiki.unige.ch/en/HTML5_audio_and_video

Tests: http://tecfa.unige.ch/guides/html/html5-video/html5-video-simple.html

Re: Re: Re: Re: Problème d'affichage d'un clip youtube dans un slide avec impress.js -- Mohamed (discussion) 8 novembre 2013 à 14:05 (CET)
Effectivement avec "webm" ça marche mieux. J'ai pu tester avec firefox et Chrome.

http://tecfaetu.unige.ch/etu-maltt/tetris/alfallo7/stic-1/ex1/tache5/ex1_tache5.html